Le Forum bouge

A lire avant de commencer...
Répondre
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

J'ai bricolé un truc sale pour corriger un problème technique, je le note parce qu'il faudra que je le remette après la prochaine mise à jour :
Modification de phpbb_cache_moderators() dans functions_admin.php:

// PVU 20230312: SET SQL_BIG_SELECTS=1 to avoid error
// The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET MAX_JOIN_SIZE=# if the SELECT is okay
$db->sql_query('SET SQL_BIG_SELECTS=1');

Autre bricolage : autoriser les réponses vides dans les questionnaires avec cases à cocher (mais ça ne devrait pas être perdu parce qu'il n'y a pas de mises à jour de cette partie)

A faire :
- changer notre hébergement pour être sur un serveur de base de données plus récente que l'antique mySQL sur lequel on est depuis très très longtemps (d'où la perte des messages) => ça attendra la fin de saison
- modifier les questionnaires pour permettre de choisir le type de décompte par défaut
- corriger la gestion des questionnaires pour le chargement des questions (qui ne fait rien la première fois)
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

Pour ceux qui, comme moi, ne l'avait pas remarqué, il est possible de cacher les questionnaires pour qu'ils n'encombrent pas l'écran, avec "Cacher le questionnaire" :
image.png
Ça donne le résultat suivant et vous pouvez ré-afficher avec "Afficher le questionnaire" :
image.png
Je vais peut-être le rendre caché par défaut sur téléphone. Ou faire en sorte de ne pas afficher les réponses des autres par défaut mais de laisser la ligne pour répondre.
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

2 nouvelles corrections automatiques du mot "saynète", parce que vous imaginez régulièrement de nouvelles orthographes exotiques. Je ne dénoncerai personne, mais en fait si : cette fois c'est Caroline et Marina.
Les autres, ne faites pas les malins, je suis sûr que vous vous plantez aussi, sauf que je ne le vois pas, justement grâce aux corrections automatiques /anabelle/
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

Comme vous l'avez vu, le forum et le site ont changé d'hébergement et sont passés en https. Il reste visiblement un problème sur les pièces jointes (et sur le package de langue dans l'écran d'admin), je suis en train de regarder.
Visiblement, ma sauvegarde a corrompu les fichiers.
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

Bon, les pièces jointes, c'est réglé, problème classique de mode de transfert FTP (ASCII/binaire). Ça doit être la même chose pour le package de langue, et il y a peut-être d'autres trucs du même genre, donc n'hésitez pas à me signaler les problèmes.
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

Et problème de package de langue réglé de la même manière.
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

Il y avait un problème d'inscription pour les nouveaux depuis le changement d'hébergeur, je viens de le régler (une question d'option PHP).
Avatar de l’utilisateur
pvu
Administrateur - Site Admin
Messages : 4811
Inscription : 27 sept. 2009 20:51
Localisation : Montpellier
Contact :

Re: Le Forum bouge

Message par pvu »

Quelques modifications techniques effectuées : remplacement des JPEG par des WEBP, pour accélérer le chargement (il faut encore que je remplace les icônes des forums, j'ai juste fait les fonds d'écran), limitation de la taille de l'affichage des avatars et des ajustements cosmétiques. Si vous repérez des défauts, faites Ctrl + F5 pour mettre à jour le cache et si ça persiste, prévenez-moi.
Répondre